Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 21, 2025 - 21:00 EST
Scheduled
We will be performing routine scheduled maintenance. During this time the LMS and API services will be unavailable.
Posted Feb 13, 2025 - 21:24 EST
This scheduled maintenance affected: SOAP API - webservices.citiprogram.org and Learning Management System - www.citiprogram.org (LMS, Email Services).