Issues with Email Delivery
Incident Report for CITI Program Status Page
Resolved
The issues with email delivery have now been resolved.
Posted Jan 04, 2023 - 22:06 EST
Monitoring
Email delivery is resuming. We are continuing to monitor the flow of email.
Posted Jan 04, 2023 - 21:03 EST
Investigating
We are currently experiencing issues with the delivery of email.
Posted Jan 04, 2023 - 18:30 EST
This incident affected: Learning Management System - www.citiprogram.org (LMS).