CE and independent learner purchases via the LMS are now available.
Posted Oct 28, 2024 - 20:40 EDT
Investigating
We are currently investigating an issue with our tax calculation service provider. Users will not be able to make CE or independent learner purchases via the LMS while the tax calculation service is unavailable.
Posted Oct 28, 2024 - 18:44 EDT
This incident affected: Learning Management System - www.citiprogram.org (LMS).