Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 07, 2025 - 21:00 EST
Scheduled
We will be performing routine scheduled maintenance. During this time you may experience intermittent connection issues when accessing the LMS and API services.
Posted Mar 01, 2025 - 00:08 EST
This scheduled maintenance affected: SOAP API - webservices.citiprogram.org and Learning Management System - www.citiprogram.org (LMS).