Slow delivery of LMS Emails

Incident Report for CITI Program Status Page

Resolved

This incident has been resolved.
Posted Dec 20, 2024 - 06:15 EST

Update

Email service has been restored. Our email provider has informed us that their engineering team has resolved the issue and taken steps so that it does not reoccur.
Posted Dec 20, 2024 - 06:14 EST

Identified

Our email provider is experiencing degraded performance. Emails sent from the LMS, including username reminders and password resets, may be delayed.
Posted Dec 19, 2024 - 15:16 EST
This incident affected: Learning Management System - www.citiprogram.org (Email Services).